วิธีตรวจสอบว่าเว็บ WordPress ของเราใช้กับ PHP เวอร์ชั่นใหม่ๆได้หรือเปล่า

สำหรับใครที่ใช้ WordPress อยู่แล้วแล้วกำลังอยากจะเปลี่ยนมาใช้ WordPress กับ PHP7 ที่หลายๆคนบอกว่าเปลี่ยนมาใช้งานแล้วเร็วขึ้นมาก บางคนก็อาจจะกลัวว่าถ้าเปลี่ยนไปใช้ PHP7 แล้ว Plugin ของเรา หรือ Theme ของเรา จะสามารถใช้งานกับ PHP7 ได้ไหม เว็บจะพังไหม?
ในบทความนี้ก็จะมาสอนวิธีการตรวจสอบว่าเว็บ WordPress ของเรานั้น มี Plugin หรือ Theme ที่เข้ากันได้กับ PHP7 หรือเปล่า? หรือเวอร์ชั่นอื่นๆก็ได้นะ โดยเราจะตรวจสอบโดยใช้ Plugin ที่ชื่อว่า PHP Compatibility Checker สามารถไปดาวโหลดกันได้ที่ https://srd.wordpress.org/plugins/php-compatibility-checker

โดยวิธีใช้งานหลังจากติดตั้ง Plugin PHP Compatibility Checker แล้ว ก็ให้เราไปที่ Tools แล้วเลือก PHP Compatibility



เสร็จแล้วทำการเลือกรุ่นของ PHP ที่จะตรวจสอบ และ เลือกว่าจะตรวจสอบกับ Plugin และ Theme ที่กำลังใช้งานอยู่ หรือว่า จะตรวจสอบทั้งหมดเลย ในภาพนี้เลือกเฉพาะที่ใช้งานอยู่นะ แล้วกดปุ่ม Scan site ได้เลย

รอสักพัก Plugin จะแสดงผลออกมาว่าตัวไหนผ่าน ไม่ผ่านบ้าง จากรูปนี้ มีตัวหนึ่ง Cloudflare ไม่ผ่าน เราสามารถกดดูรายละเอียดได้ที่ Toggle detail ถ้าผ่านหมดก็สามารถอัพเกรด PHP ไปใช้กับ PHP 7 หรือเวอร์ชั่นที่เราต้องการใช้งานได้โดยไม่ต้องกังวล